Foro de Soporte

problemas de conexion de base datos web 2013-06-21 06:50
david1986

saludos cordiales.
necesito su ayuda ,ten gon este error que se me presenta al hacer la consulta de login en un form llamado princip1, para verificar si es administrador o usuario el que se conecta a la base de datos...

Warning: mysql_connect (): 'hostingeres' Desconocido MySQL anfitrión del servidor (1) en / home/u260301505/public_html/princip1.php on line 65 Warning: mysql_query () espera parámetro 2 sea de recursos, boolean given in / home/u260301505 / public_html/princip1.php on line 67


---------------------
adjunto el form para q lo chequeen haber q esta mal

<?php
mysql_connect("servosor", "usuario", "clave");
mysql_select_db("base de datos web");
?>

<?php
if (!function_exists("GetSQLValueString")) {
function GetSQLValueString($theValue, $theType, $theDefinedValue = "", $theNotDefinedValue = "")
{
if (PHP_VERSION < 6) {
$theValue = get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue;
}

$theValue = function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : mysql_escape_string($theValue);

switch ($theType) {
case "text":
$theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";
break;
case "long":
case "int":
$theValue = ($theValue != "") ? intval($theValue) : "NULL";
break;
case "double":
$theValue = ($theValue != "") ? doubleval($theValue) : "NULL";
break;
case "date":
$theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";
break;
case "defined":
$theValue = ($theValue != "") ? $theDefinedValue : $theNotDefinedValue;
break;
}
return $theValue;
}
}
?>
<?php
// *** Validate request to login to this site.


if (!isset($_SESSION)) {
session_start();
}

$loginFormAction = $_SERVER['PHP_SELF'];
if (isset($_GET['accesscheck'])) {
$_SESSION['PrevUrl'] = $_GET['accesscheck'];
}

if (isset($_POST['Usuario'])) {
$loginUsername=$_POST['Usuario'];
$password=$_POST['Usuario2'];
$MM_fldUserAuthorization = "admin_priv";
$MM_redirectLoginSuccess = "formmenuuser.php";
$MM_redirectLoginFailed = "fallo.php";
$MM_redirecttoReferrer = false;
mysql_select_db("u260301505_web");



$LoginRS__query=sprintf("SELECT nombreusuario, contrasena, admin_priv FROM nivelusuarios WHERE nombreusuario=%s AND contrasena=%s",
GetSQLValueString($loginUsername, "text"), GetSQLValueString($password, "text"));

$recurso = mysql_connect($servidor, $usuario, $clave);
mysql_select_db("u260301505_web");
$LoginRS = mysql_query($LoginRS__query, $recurso) or die(mysql_error());
if ($loginFoundUser) {

$loginStrGroup = mysql_result($LoginRS,0,'admin_priv');

if (PHP_VERSION >= 5.1) {session_regenerate_id(true);} else {session_regenerate_id();}



//declare two session variables and assign them
$_SESSION['MM_Username'] = $loginUsername;
$_SESSION['MM_UserGroup'] = $loginStrGroup;

if (isset($_SESSION['PrevUrl']) && false) {
$MM_redirectLoginSuccess = $_SESSION['PrevUrl'];
}
header("Location: " . $MM_redirectLoginSuccess );
}
else {
header("Location: ". $MM_redirectLoginFailed );
}
}
?>


CITA
Re: problemas de conexion de base datos web 2013-06-21 07:51
d3iti

david1986 escribió: saludos cordiales.
necesito su ayuda ,ten gon este error que se me presenta al hacer la consulta de login en un form llamado princip1, para verificar si es administrador o usuario el que se conecta a la base de datos...

Warning: mysql_connect (): 'hostingeres' Desconocido MySQL anfitrión del servidor (1) en / home/u260301505/public_html/princip1.php on line 65 Warning: mysql_query () espera parámetro 2 sea de recursos, boolean given in / home/u260301505 / public_html/princip1.php on line 67


---------------------
adjunto el form para q lo chequeen haber q esta mal

<?php
mysql_connect("servosor", "usuario", "clave");
mysql_select_db("base de datos web");
?>

<?php
if (!function_exists("GetSQLValueString")) {
function GetSQLValueString($theValue, $theType, $theDefinedValue = "", $theNotDefinedValue = "")
{
if (PHP_VERSION < 6) {
$theValue = get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue;
}

$theValue = function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : mysql_escape_string($theValue);

switch ($theType) {
case "text":
$theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";
break;
case "long":
case "int":
$theValue = ($theValue != "") ? intval($theValue) : "NULL";
break;
case "double":
$theValue = ($theValue != "") ? doubleval($theValue) : "NULL";
break;
case "date":
$theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";
break;
case "defined":
$theValue = ($theValue != "") ? $theDefinedValue : $theNotDefinedValue;
break;
}
return $theValue;
}
}
?>
<?php
// *** Validate request to login to this site.


if (!isset($_SESSION)) {
session_start();
}

$loginFormAction = $_SERVER['PHP_SELF'];
if (isset($_GET['accesscheck'])) {
$_SESSION['PrevUrl'] = $_GET['accesscheck'];
}

if (isset($_POST['Usuario'])) {
$loginUsername=$_POST['Usuario'];
$password=$_POST['Usuario2'];
$MM_fldUserAuthorization = "admin_priv";
$MM_redirectLoginSuccess = "formmenuuser.php";
$MM_redirectLoginFailed = "fallo.php";
$MM_redirecttoReferrer = false;
mysql_select_db("u260301505_web");



$LoginRS__query=sprintf("SELECT nombreusuario, contrasena, admin_priv FROM nivelusuarios WHERE nombreusuario=%s AND contrasena=%s",
GetSQLValueString($loginUsername, "text"), GetSQLValueString($password, "text"));

$recurso = mysql_connect($servidor, $usuario, $clave);
mysql_select_db("u260301505_web");
$LoginRS = mysql_query($LoginRS__query, $recurso) or die(mysql_error());
if ($loginFoundUser) {

$loginStrGroup = mysql_result($LoginRS,0,'admin_priv');

if (PHP_VERSION >= 5.1) {session_regenerate_id(true);} else {session_regenerate_id();}



//declare two session variables and assign them
$_SESSION['MM_Username'] = $loginUsername;
$_SESSION['MM_UserGroup'] = $loginStrGroup;

if (isset($_SESSION['PrevUrl']) && false) {
$MM_redirectLoginSuccess = $_SESSION['PrevUrl'];
}
header("Location: " . $MM_redirectLoginSuccess );
}
else {
header("Location: ". $MM_redirectLoginFailed );
}
}
?>



El problema que yo veo parece estar con la conexión. Fíjate que en código que has puesto haces dos conexiones distintas(con datos distintos) en la primera línea y en una línea más abajo con la siguiente instrucción:

mysql_connect("servosor", "usuario", "clave");
...
$recurso = mysql_connect($servidor, $usuario, $clave);


Comprueba que los datos(parámetros) que usas en las dos líneas anteriores son correctos(compáralos con los que se muestran en la opción "Panel de Control" -> MySQL), comenzando por el nombre del servidor (primer parámetro de la función mysql_connect ).


Moderador voluntario del foro.
CITA

¿Qué está sucediendo?
Estadísticas del Foro
Temas: 1462, Publicaciones: 6539
Miembros: 3297, Miembros Activos: 2709
Le damos la bienvenida a nuestro miembro más reciente, GerardoVelez